Issues/Error running PingPong example PreviousNext
Data Distribution Service (DDS) Forum > DDS Technical Forum >
Message/Author
Next message shawn.bruman@elbitsystem-us.com  posted on Wednesday, May 12, 2010 - 04:29 pm
Running the PingPong example (Windows and Linux)Gives the following issues for larger values.

It runs fine for the default values of nof_blocks 100 and nof_cycles 100.

Changing the nof_blocks to 1000 will cause an error message of "message lost".

Changing the nof_blocks to 10000 will cause a segmentation fault.

Is there a configuration value that needs to change or is it a software issue.
Next message Hans van 't Hag  posted on Wednesday, May 12, 2010 - 04:58 pm
Hi Shawn,

If you run the 'mmstat' tool in parallel with the pingpong execution, you'll notice that the shared-memory gets exhausted as the block-nr is a key-value in the data-model which increases with each cycle thus allowing to verify the impact of a growing database on the performance.

As the application doesn't impose any resource-limits it will exhaust the 10 Mbyte shared-memory-segment causing the segfault (we'll make this more 'graceful' in upcoming releases of the product)..

Regards,
Hans
Next message Hans van 't Hag  posted on Wednesday, May 12, 2010 - 04:59 pm
Also.. you might consider to address these kinds of issues/questions at our developer-mailing list to which you can subscribe at http://www.opensplice.org/cgi-bin/twiki/view/Community/MailingLists#developer_op ensplice_org as there are many valuable discusions going on there and its product-specific (whereas this forum isn't :-) )
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action: