OpenSplice DDS - Problem first usage PreviousNext
Data Distribution Service (DDS) Forum > DDS Technical Forum >
Message/Author
Next message Hatem Arous  posted on Thursday, May 06, 2010 - 02:10 pm
Hi,

I start using opensplice DDS (Community version) recently but I have a problem.
I strated the process (ospl.exe start) and recompile the example (Chat).
All appears OK.
But when I want to start the Chat application (C:\OpenSpliceDDSV5.1-x86.win32-vs2008-HDE\HDE\x86.win32\examples\dcps\standalon e\Java\Tutorial>java -classpath "%OSPL_HOME%/jar/dcpssaj.jar;bld" chatroom.Chatter)

an error notification appears : Error in DDS.DomainParticipantFactory.create_participant: Creation failed: invalid handle

can someone help me please?

thx in advance
Next message Niels Kortstee  posted on Thursday, May 06, 2010 - 03:39 pm
Hi Hatem,

Did you start OpenSplice before running your application?

Regards, Niels
Next message Hatem Arous  posted on Thursday, May 06, 2010 - 03:55 pm
yes
I started it using command : ospl.exe start

--
Best Regards,
Hatem
Next message Hatem Arous  posted on Friday, May 07, 2010 - 09:08 am
Hi,

It work now!!! :-)

I think that I had 2 OSPL instances started.
I stopped OSPL (ospl.exe stop) and when I restarted it, it works.

--
Best Reagards
Hatem
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action: