OpenSplice Source Build Solaris 10 PreviousNext
Data Distribution Service (DDS) Forum > DDS Technical Forum >
Message/Author
Next message David Sargrad  posted on Monday, January 18, 2010 - 04:39 pm
I'm trying to build the opensplice distro on solaris 10. I have not gotten very far without seeing an error message.

I've opened a bash shell and have typed
source configure

I see several lines of feedback. Amongst other things it says
"Error - Only JAVA 1.5 and above is supported".

There are then a couple of lines of feedback relative to the absence of TAO and JACORB (not a problem for me)

The last message simply says "Configuration Invalid". It doesnt say what makes it invalid, though I've got to assume its the java issue.

I dont need any java language support, and so i have not defined JAVA_HOME.

I'd like to build with gcc. I did notice that there is a javac in bin (I think it was installed with sunstudio). Perhaps the configure is finding this and complaining about it.

Though I dont require java language support, we are going ahead and trying to install the JDK on this sun box.

How can I get past this?

Thanks in advance.
Next message David Sargrad  posted on Monday, January 18, 2010 - 05:05 pm
I dug into the opensplice build scripts a bit. Sure enough I found a file called "checkconf" this file has the code that checks for javac. The default behaviour is to look to see if JAVA_HOME is defined. If it is then it looks for javac there. If it isnt' then it looks for javac in the path. This is a bit unfortunate since the only way to not compile with java language support is to ensure that javac is not in your path.

It would be easier if I could just avoid defining JAVA_HOME, or if there is a configuration file that allows me to enable/disable java language support.

For now we are installking the jdk, though I dont really need/want it.
Back to top
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Post as "Anonymous"
Enable HTML code in message
Automatically activate URLs in message
Action: